Back to overview
Resolved

System Maintenance

Jun 16, 2026 at 8:00pm UTC  –  Jun 16, 2026 at 8:55pm UTC
Affected services
Actionable Insights portal
Launchpad for service Teams App
Service compliance portal
Digital Platform for Service (DPS)
GSS Shared Infrastructure and Team Resources
Service Graph
OCPLM File Fetcher
Sierra Utility Platform

Resolved
Jun 16, 2026 at 8:55pm UTC

Maintenance ended

Updated
Jun 16, 2026 at 8:55pm UTC

Deployment of our services have completed. The system continues to be in hypercare. Please reach out if you see any anomalies.

Created
Jun 16, 2026 at 8:00pm UTC

The GSS Software Team will be updating the our backend infrastructure.

We do not expect any interruptions during this time, please reach out if you are experiencing any issues.