Back to overview
Downtime
Service Interruption
Nov 19 at 02:35pm PST
Affected services
Actionable Insights portal
Launchpad for service Teams App
Resolved
Nov 19 at 02:51pm PST
Our services have restarted and are back online.
Affected services
Actionable Insights portal
Launchpad for service Teams App
Updated
Nov 19 at 02:46pm PST
We have identified the issue and we're working on resolving it.
Affected services
Actionable Insights portal
Launchpad for service Teams App
Created
Nov 19 at 02:35pm PST
We're investigating an issue with the Digital Platform for Service.
Affected services
Actionable Insights portal
Launchpad for service Teams App